APOGEE Desktop Client Help

Contents

Video demo

To view a short video demonstration of the APOGEE Desktop Client, click here.

Launching the APOGEE Desktop Client

The APOGEE Desktop Client is distributed both as a Java Web Start (JWS) application and as a ZIP archive containing an executable JAR file. By launching the program using JWS, you can take advantage of automatic software updates.

To run the APOGEE Desktop Client using JWS, click the launch button below.

Users who which to download the ZIP archive should follow the instructions for downloading and running the APOGEE Desktop Client.

Starting a project

To start a project, launch the APOGEE Desktop Client and select File → New Project. A dialog will appear prompting you to select the class of the problem:

Standard
The topology is fixed; no pool–pool connections exist.
Generalized
The topology should be treated as a decision variable and/or the problem includes pool–pool connections.† Quality levels may be reduced in pool nodes (i.e., pools may function as treatment plants).
Extended
The problem includes constraints based on the Environmental Protection Agency Title 40 Code of Federal Regulations Part 80.45: Complex Emissions Model (see http://www.epa.gov/oms/rfg.htm.)

After the problem class has been selected, a dialog will appear prompting you for the numbers of inputs, pools, and outputs. Selecting OK will create the corresponding nodes with default properties and place them on the graph. Nodes may also be created/deleted individually (see below).

† While pool–pool connections are allowed in the generalized problem, the optimization algorithm excludes feasible solutions in which cycles exist between pools.

Specifying a pooling problem

Specifying stream qualities

To specify monitored stream qualities, go to Edit → Stream Qualities. Units may be selected from the drop-down menu or edited manually.

Creating nodes

To create a new node, select Edit → Nodes → Insert or right click on the graph and select Insert Node.

Making connections

To connect nodes, go to Edit → Connections → Add/Remove. Alternatively, connections may be created with the cursor by clicking and dragging the mouse from source to destination. To delete connections, use the Add/Remove Connections dialog, right click a connection and select Delete, or select a connection or connections and press the Delete key.

Editing nodes and connections

To edit nodes, go to Edit → Nodes → Modify; to edit connections, go to Edit → Connections → Properties. A node or connection may also be edited by double clicking the component or right clicking and selecting Edit.

Submitting a problem to the solver

To submit a problem to the solver, first specify a save location for the project by going to File → Save As. Selecting Project → Solve Problem will save the project to this file and upload the file to the server. You will be prompted for an email address to which results should be sent.

On successful upload, you will receive a message with your job ID number. The message will also note the number of jobs in the batch server queue (including the current job). Jobs are given a maximum of 2 hours wall time to complete; however, the typical (moderately complex) problem takes much less time to converge to optimality.

Viewing results

When your job has completed, you will receive an email with the solver results attached as an XML file. Download the file and open it in the APOGEE Desktop Client. To view a summary of the results, go to Project → Solver Results. You may also view the flowrate assigned to a particular node or connection by dragging the mouse over the corresponding graph element.

Exporting results

To export results in Microsoft Excel (.xls) format, go to File → Export Results → MS Excel and specify a filename. A workbook will be created containing summary worksheets for inputs, pools, outputs, and connections.